IBM DataPower Operations Dashboard v1.0.14.0
A newer version of this product documentation is available.
You are viewing an older version. View latest at IBM DPOD Documentation.
Admin Console is not Responding in 1.0.13.0-1.0.14.0
Symptoms
The Admin Console is up and running for at least several weeks.
The Admin Console is not responding (
/admin
endpoint never finishes loading).The log files under
/logs/appadmin
contain the following error message:java.lang.OutOfMemoryError: Java heap space
DPOD version is 1.0.13.0-1.0.14.0
Note:Â DPOD 1.0.15.0 will fix this issue.
Cause
The Admin Console runs out of memory due to a memory leak in one of the libraries of the Java application server.
Resolution
As a temporary workaround, until DPOD 1.0.15.0 is available, you may issue the following commands:
sed -i '\#^jms/MonTierAMQResourceAdapter.KeepAliveTime=#d' /app/appadmin/MonTier-AppAdmin/conf/system.properties
echo "" >> /app/appadmin/MonTier-AppAdmin/conf/system.properties
echo "jms/MonTierAMQResourceAdapter.KeepAliveTime=600s" >> /app/appadmin/MonTier-AppAdmin/conf/system.properties
service MonTier-AppAdmin restart
Once you upgrade to DPOD 1.0.15.0, you may use the following command to remove this workaround:
sed -i '\#^jms/MonTierAMQResourceAdapter.KeepAliveTime=#d' /app/appadmin/MonTier-AppAdmin/conf/system.properties
service MonTier-AppAdmin restart