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Symptoms

  • An "Error Accessing Store" dialog is displayed after signing in to the system:

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  • In the Store page, the status of the cluster is RED with unassigned shards:

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Cause

This situation is usually caused by an unexpected recovery of the Store, where automatic assignment of shards was not applicable at the time of recovery for some reason. For example, this might be caused by an I/O error of the storage device or emergency reboot of the machine.

The Store is divided into nodes, some used to keep data, others can handle communications or manage the Store. Shards must be allocated/assigned to Store data nodes in order to be able to be populated with data. If some shards are unassigned to a data node, then no data can be persisted in the system.

Resolution

Use Reallocating Unassigned Shards utility in Admin Console. The  The utility scans all shards and reallocates unassigned shards to the data node provided.

This operation may take a while, depending on your installation and the amount of data.

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