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The Device and Domain fields of a transaction show “Unknown” instead of the correct value.

 


Implications

Transactions, domain activity and system errors will show as "Unknown", the user will not be able to view or filter by the correct device or domain name. 


Cause

There are three possible causes:

1. Replacing an existing DPOD installation for a DataPower device
2. Adding a new monitored device or domain
3. Internal error in DPOD's ElasticSearch agent 


Solution

  1. If you replaced an existing DPOD installation for a DataPower device, go to DPOD’s manage menu, under Devices choose “Monitored Devices”, click the device and under the “Setup” tab click “Setup Syslog for Device” and “Setup Syslog for all domains”.
    The correct device and domain names will appear in few minutes.
  2. When adding a new device or domain - wait 1-2 minutes for DPOD to cache and show the new name.
  3. if you didn't replace an existing DPOD installation, and didn't add a new device or domain - check the health of the ElasticSearch agent, you may need to reallocate unassigned shards or restart the agent via the CLI