Symptoms
Transactions payload is not displayed although Payload Capturing using WS-M is enabled.
Cause
There are several reasons why payloads may not show in DPOD:
- Payloads capture is not supported
- Payloads are not being sent
- Payloads capture has errors, or filtered out in DPOD
- Payloads are fully collected in DPOD, but are still not displayed
Resolution
Perform the following checks to find the cause in your case: .
Payloads capture is not supported
Payload capture is only supported for:1) WS
- WS Proxy objects in any firware 6.1.X and above
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- MPGW objects from IDG firmware 7.5.2 and DPOD 1.0.2 (text payloads only)
To see payloads on a non-supported object type and/or versions please upgrade or submit an RFE.
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- Verify the DPOD WS-M agent is up and running - Check System Services Status with the CLI.
- Verify that the DPOD WS-M agent status is green on Check System Status Using the Web Console. This means that the keep alive message are processed.
Inspect the WS-M logs for any exceptions. Logs may be accessed using Telnet, at the following path: /logs/wsmAgents/<Agent-name>/agent-flume_<Agent-name>.log.
Normal WS-M log records should show:11/10/XXXX 08:26:03,477- INFO o.m.a.f.h.NHttpFileServer [I/O-dispatch-2] wsmHttpSource1 Incoming entity content (bytes): 2908. ← an actual payload arrived
11/10/XXXX 08:26:10,166- INFO o.m.a.f.h.NHttpFileServer [I/O-dispatch-3] wsmHttpSource1 Incoming entity content (bytes): 2220. ← size 2220 means usually keep alive message
To find exceptions in your logs, enter the search term ' ERROR ' (leading and trailing space). Contact support with any exception found.
- In some cases DPOD may filter messages out because of their size. Please see the following technote: WS-M large payloads are not displayed
Payloads are fully collected in DPOD, but are still not displayed
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